Decoder für D143 - Entwicklungsversuch!

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Decoder für D143 - Entwicklungsversuch!

      Hallo und guten Abend,

      da ich gern alle meine GO!!! Autos digital Fahren möchte bin ich schon länger auf der Such nach günstigen Decodern.
      Das gestaltet sich aber schwierig, jedenfalls wenn´s nicht viel kosten soll.

      Ich hätte gern alle Funktionen der original D143 Decoder, plus einstellbare Höchstgeschwindigkeit, Bremse und evtl. noch schaltbares Licht.

      Die Entwicklung soll Schritt für Schritt gemacht werden.

      Erstes Ziel: FAHREN!

      Mit den im Netz verfügbaren Infos war das lesen der Schienensignale und das Umsetzten der Motor-PWM nicht dramatisch.

      youtube.com/watch?v=36q7Jy0ZQ8c&feature=youtu.be

      Allerdings sind die Arduino-Bibliotheken die einem das Leben schön leicht machen nicht zimperlich im Speicherverbrauch.
      Bis hier geht das Programm schon nicht mehr auf den ATTiny25 mit seien 2KBytes . Also hab ich jetzt ein paar ATTiny85 mit 8KBytes und ein EVO-Board mit ein 85er drauf geordert.

      Wenn das da Ist, kommt das mit der Motor-Elektronik auf ein Chassis zur Fahrerprobung.

      Gruß
      Enrico
    • Hurra, Hurra die Post ist da....

      ATTiny85.JPG

      Ruck-Zuck geliefert.
      Ein ATTiny85-20 im handlichen DIP Sockel und ein USB EVO-Board mit dem gleichen µC.

      Einbindung in die Arduino IDE ist schnell gemacht. Dann das Programm vom UNO Board drauf und ..... peng! Compilerfehler....Hmmmm ?(

      Die Fehlermeldung läßt einen Verdacht aufkommen. Richtig! Die prima PWM-Bibliothek läuft nur auf den ATMega Chips. SEHR SCHÖN!


      Jetzt gibt es zwei Möglichkeiten:

      1. einfach den ATTiny wegschmeißen und nen ATMega16 nehmen...
      oder
      2. Die PWM mit Timer selber machen.


      Preislich sind das nur etwa 50ct. Der Mega hat allerdings viel mehr Pins und erfordert noch mehr Geschick beim löten...
      Und Carrera hat das ja sogar mit dem ATTiny25 geschafft....

      Da muß ich wohl nochmal drüber nachdenken.

      Enrico
    • Bevor ich einen Mega nehme, würde ich gleich auf einen 8266 wechseln.
      5 mal mehr Leistung und 8 mal so viel Speicher bei gleichen Gewicht.

      PWM sollte jedoch nicht wirklich ein Problem sein?

      Der gesamte Befehlssatz ist zwar auf wenige C Befehle eingegrenzt.
      Doch wirklich schwierig ist das nicht.
      Landschaftsmodellbauer mit 2 für Autorennen begeistern Söhnen.
    • Nabend...

      ein Schritt ist geschafft!
      Das Programm läuft auf dem Attiny85 und die ersten Fahrversuche können beginnen.

      Ich habe zuerst mit dem Evo-Board experimentiert, aber das Gerät ist für diesen Zweck nicht geeignet.
      Die Pins sind für die Programmierung fest mit dem USB Anschluß verbunden und kommen so in Konflikt damit.

      Irgend etwas hat sich immer gegenseitig gestört und das Board wartet nach dem Start immer erst für ein paar Sekunden auf den Bootloader.
      Das geht natürlich im Auto gar nicht.

      Auf dem einzelnen µC läuft es jetzt ganz ordentlich. Die rote LED hängt am Motorausgang.

      youtu.be/tpuLNzpfBGg



      Nächster Schritt:

      Den Chip auf eine Lochrasterplatine, Motor-FET und Programmierschnittstelle dazu und das ganze auf das Chassis schrauben.
      Und dann mal sehen wie es fährt!

      Gruß
      Enrico
    • Ein interessanter Nebeneffekt, man kann die Frequenz der Motor-PWM ändern und an den verwendeten Motor anpassen und die IR- LED kann natürlich auch auf Fahrzeuge-ID 7 oder 8 eingestellt werden, also Ghostcar.

      Ich denke aber man braucht dafür einen separaten Programmierer.
      Aber so ein Gerät ist ohnehin ganz nützlich wenn man bei laufendem Rennen mal schnell ein Auto programmieren will.

      Enrico
    • also ich muß gestehen, ich mag es wenn ein Auto vollkommen ruhig über die Bahn fährt.
      Das Geräsuch eines E-Motors ist vollkommen okay...

      bei Slotcars gilt für mich - je leiser desto besser, dann kann wenigstens noch nebenbei Musik hören.

      vielleicht ein Sache des Alters, aber ich bin heilfroh das mein neues Motorrad einen leisen Serienauspuff drauf hat. Auch wenn ich den Klang von meinem untypisiertem Sebring 4-in-nichts Auspuff vom V4-Motor über alles geliebt habe. Das Geräusch vom V4 ist für mich unübertroffen, aber leiser ist auf Dauer doch angenehmer ...
    • Moin...

      Karneval ist vorbei und ich kann mich wieder wichtigen Dingen widmen.

      Der erste Fahrtest stand ja nun an und darum wurde ein F1 Chassis hergerichtet.

      Testwagen.jpg

      Nicht schön, aber praktisch.... :D

      Die IR-LED ist auch schon drin, aber noch nicht in Betrieb. Erstmal will ich die Fahreigenschaften testen.

      youtube.com/embed/Jau2UtyiXv0

      Er rollt! Und ist verdammt schnell. Jetzt brauche ich eine vernünftige Teststrecke um das verhalten z.B. auf Weichen (Stromunterbrechungen) zu prüfen.
      Nächster Schritt:

      IR-LED in Betrieb nehmen und ID-Programmierung.


      Gruß
      Enrico
    • Inzwischen habe ich den Kreis um ein paar Geraden und zwei Weichen erweitert.
      Beim überfahren der Weichen und damit der kurzzeitigen Trennung der Stromversorgung gab es Probleme.

      Es entstanden alle möglichen interessanten Reaktionen. Stehen bleiben, Vollgas, weiterfahren ohne auf den Regler zu reagieren.....

      Ganz eindeutig ein Programmabsturz im µC durch undefinierte Spannungen. Um dies zu verhindern verfügt der ATTiny über eine brown out detection, die die Versorgungsspannung überwacht und bei erreichen eines Grenzwertes den Chip sauber resetted bevor sich das Programm im µC aufhängen kann.

      Laut Datenblatt ist die Funktion standardmäßig Ausgeschaltet. Nach einigem gefummel gelang es auch mit Hilfe der Arduino IDE die passenden Fuses zu setzten und brown out detection zu aktivieren.

      Und siehe....

      Die zickereinen an den Weichen sind wie weggeblasen. ;)

      Beim Vergleichsfahren mit einem originalen D143 Decoder fällt jetzt noch ein stärkeres Abbremsen nach der Weiche auf.
      Scheinbar braucht der µC zu lange um wieder ein gültiges Signal zu erkennen oder der Bootvorgang dauert zu lange.

      Komischer Weise tritt das Problem nur auf, wenn die Weiche geradeaus überfahren wird. Biegt man ab, ist alles in Ordnung.

      Ich rüste jetzt mal die IR-LED nach. Damit verliert der µC schneller die Spannung, was schon helfen könnte.
      Außerdem ändere ich den Programmteil für die Auswertung der Reglerdaten. Da kann ich vermutlich noch einiges an Zeit sparen um ein gültiges Reglerdatenwort zu empfangen.


      Gruß
      Enrico
    • Decoder für D143 - Entwicklungsversuch!

      Ich würde in diesem Zusammenhang versuchen, die Vcc am C mithilfe eines passenden Kondensators zu puffern. Muss ja kein Goldcap sein, aber etwas mehr als gar nix könnte schon helfen, solche kurzzeitigen Spannungseinbrüche zu überbrücken.
      Ich würde mal so mit 470nF oder 1uF 10V anfangen.